Selecciona una categoría
Mapa del sitio Ayuda Contacto
print article

Actualización de sistemas operativos Linux en planes 1&1 Hosting y servidores

Artículo válido para packs 1&1 Hosting con sistemas operativos Linux

Estamos actualizando los sistemas operativos Linux en nuestros equipos de 1&1 Hosting y 1&1 servidores. Esto te permitirá beneficiarte de un mejor aprovechamiento de los recursos, un sistema de seguridad mejorado y el uso de protocolos de seguridad actuales como TLS 1.2.

Con esta actualización, se usarán nuevas versiones de lenguajes de programación, así como nuevas librerías de bases de datos. Si usas uno de los siguientes lenguajes de programación o una de estas librerías en tu web, asegúrate de que tus scripts son compatibles con las siguientes versiones:

Nuevas versiones:
  • Perl 5.20
  • Python 2.70 y 3.4
  • Ruby 2.1
  • Berkely DB 5.3
Otros paquetes de software actualizados:
  • Nueva versión de servidor web: Apache 2.4
  • Protocolo de seguridad mejorado: TLS 1.2
  • Arquitectura moderna: soporte para 64 bits (se desactiva el soporte para 32 bits)
A tener en cuenta:
Si usas aplicaciones de 32 bits como son ionCube Loader o Zend Guard Loader, por favor, actualízalas a sus versiones de 64 bits. Para ello, sigue las instrucciones de estos dos artículos de nuestro 1&1 Centro de ayuda:

Instalación manual de ionCube Loader

Instalación manual de Zend Guard Loader

Con la actualización del servidor web Apache 2.4 es posible que algunas directivas antiguas causen un error interno del servidor al acceder a tu web y usar un archivo .htaccess. Para encontrar la directiva que causa el error, sigue estas instrucciones:

Paso 1
Descarga el archivo .htaccess a través de FTP o 1&1 Administración de Archivos.
Paso 2
Abre el archivo con un editor de texto plano, como por ejemplo el bloc de notas.
Paso 3
Añade un signo de número (#) al inicio de la primera línea. Esto hará que dicha línea pase a ser un comentario, con lo que el comando no se ejecutará y no necesitarás escribir todo el comando de nuevo cuando quieras volver a utilizarlo.
Paso 4
Guarda los cambios.
Paso 5
Sube el archivo .htaccess de nuevo a tu espacio web.
Paso 6
Accede a tu web y comprueba si el error interno del servidor sigue ocurriendo.
Paso 7
Si el error persiste, edita nuevamente el archivo .htaccess: elimina el signo de número de la primera línea y añádela al principio de la línea siguiente. Continúa el proceso hasta que el error interno del servidor deje de producirse. Cuando esto ocurra, habrás encontrado la directiva obsoleta.
Directiva obsoleta

Si usas la directiva Options All (-Indexes, -DirectoryListing, etc.) en el archivo .htaccess, por favor, elimina la palabra All, puesto que no es válida.

Aplicaciones Joomla!

Después de la actualización del sistema operativo, algunas instalaciones de Joomla! pueden devolver el siguiente error: require_once 'cache/Lite.php';

Para solucionar este error, edita el archivo configuration.php del directorio principal de Joomla!. Para ello:

1. Busca la línea public $cache_handler = 'cache lite';
2. Sustituye dicha línea por public $cache_handler = 'file';
3. Guarda los cambios y suba el archivo de nuevo.

Ahora tu web ya será accesible.